CVEvulnerability
CVE-2022-3474
5.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-10-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 5.1 MEDIUM — CVSS:4.0/AV:A/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-522
Description
A bad credential handling in the remote assets API for Bazel versions prior to 5.3.2 and 4.2.3 sends all user-provided credentials instead of only the required ones for the requests. We recommend upgrading to versions later than or equal to 5.3.2 or 4.2.3.
Affected configurations
• google bazel (>= 3.1.0 < 4.2.3)
• google bazel (>= 5.0.0 < 5.3.2)
Related
Weakness · CWE (1)
- CWE-522 Insufficiently Protected Credentials weakness
References
- https://github.com/bazelbuild/bazel/security/advisories/GHSA-mxr8-q875-rhwq Third Party Advisory
- https://github.com/bazelbuild/bazel/security/advisories/GHSA-mxr8-q875-rhwq Third Party Advisory