CVEvulnerability
CVE-2022-36023
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-08-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:H
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-20
Description
Hyperledger Fabric is an enterprise-grade permissioned distributed ledger framework for developing solutions and applications. If a gateway client application sends a malformed request to a gateway peer it may crash the peer node. Version 2.4.6 checks for the malformed gateway request and returns an error to the gateway client. There are no known workarounds, users must upgrade to version 2.4.6.
Affected configurations
• hyperledger fabric (< 2.4.6)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/hyperledger/fabric/pull/3572 Patch
- https://github.com/hyperledger/fabric/pull/3576 Patch
- https://github.com/hyperledger/fabric/pull/3577 Patch
- https://github.com/hyperledger/fabric/releases/tag/v2.4.6 Release Notes
- https://github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r Third Party Advisory
- https://github.com/hyperledger/fabric/pull/3572 Patch
- https://github.com/hyperledger/fabric/pull/3576 Patch
- https://github.com/hyperledger/fabric/pull/3577 Patch
- https://github.com/hyperledger/fabric/releases/tag/v2.4.6 Release Notes
- https://github.com/hyperledger/fabric/security/advisories/GHSA-qj6r-fhrc-jj5r Third Party Advisory