CVEvulnerability
CVE-2022-36068
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-09-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-862
Description
Discourse is an open source discussion platform. In versions prior to 2.8.9 on the `stable` branch and prior to 2.9.0.beta10 on the `beta` and `tests-passed` branches, a moderator can create new and edit existing themes by using the API when they should not be able to do so. The problem is patched in version 2.8.9 on the `stable` branch and version 2.9.0.beta10 on the `beta` and `tests-passed` branches. There are no known workarounds.
Affected configurations
• discourse discourse (< 2.8.9)
• discourse discourse 2.9.0
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/discourse/discourse/commit/ae1e536e83940d58f1c79b835c75c249121c46b6 Patch, Third Party Advisory
- https://github.com/discourse/discourse/pull/18418 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-6crr-3662-263q Third Party Advisory
- https://github.com/discourse/discourse/commit/ae1e536e83940d58f1c79b835c75c249121c46b6 Patch, Third Party Advisory
- https://github.com/discourse/discourse/pull/18418 Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-6crr-3662-263q Third Party Advisory