CVEvulnerability
CVE-2022-36074
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-09-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200, CWE-863
Description
Nextcloud server is an open source personal cloud product. Affected versions of this package are vulnerable to Information Exposure which fails to strip the Authorization header on HTTP downgrade. This can lead to account access exposure and compromise. It is recommended that the Nextcloud Server is upgraded to 23.0.7 or 24.0.3. It is recommended that the Nextcloud Enterprise Server is upgraded to 22.2.11, 23.0.7 or 24.0.3. There are no known workarounds for this issue.
Affected configurations
• nextcloud nextcloud enterprise server (< 22.2.11)
• nextcloud nextcloud enterprise server (>= 23.0.0 < 23.0.7)
• nextcloud nextcloud enterprise server (>= 24.0.0 < 24.0.3)
• nextcloud nextcloud server (< 23.0.7)
• nextcloud nextcloud server (>= 24.0.0 < 24.0.3)
Related
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vqgm-f748-g76v Third Party Advisory
- https://github.com/nextcloud/server/pull/32941 Patch, Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vqgm-f748-g76v Third Party Advisory
- https://github.com/nextcloud/server/pull/32941 Patch, Third Party Advisory