CVEvulnerability
CVE-2022-36110
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-09-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-1220, CWE-285
Description
Netmaker makes networks with WireGuard. Prior to version 0.15.1, Improper Authorization functions lead to non-privileged users running privileged API calls. If someone adds users to the Netmaker platform who do not have admin privileges, they can use their auth tokens to run admin-level functions via the API. This problem has been patched in v0.15.1.
Affected configurations
• netmaker netmaker (< 0.15.1)
Related
References
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1 Third Party Advisory
- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg Third Party Advisory
- https://github.com/gravitl/netmaker/releases/tag/v0.15.1 Third Party Advisory
- https://github.com/gravitl/netmaker/security/advisories/GHSA-ggf6-638m-vqmg Third Party Advisory