CVEvulnerability
CVE-2022-36125
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-08-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-190, CWE-20
Description
It is possible to crash (panic) an application by providing a corrupted data to be read. This issue affects Rust applications using Apache Avro Rust SDK prior to 0.14.0 (previously known as avro-rs). Users should update to apache-avro version 0.14.0 which addresses this issue.
Affected configurations
• apache avro (< 0.14.0)
Related
References
- https://lists.apache.org/thread/t1r5xz0pvhm4tosqopjpj6dz8zlsht07 Mailing List, Vendor Advisory
- https://lists.apache.org/thread/t1r5xz0pvhm4tosqopjpj6dz8zlsht07 Mailing List, Vendor Advisory