CVEvulnerability
CVE-2022-37021
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-08-31
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
Apache Geode versions up to 1.12.5, 1.13.4 and 1.14.0 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 8. Any user still on Java 8 who wishes to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15 and Java 11. If upgrading to Java 11 is not possible, then upgrade to Apache Geode 1.15 and specify "--J=-Dgeode.enableGlobalSerialFilter=true" when starting any Locators or Servers. Follow the documentation for details on specifying any user classes that may be serialized/deserialized with the "serializable-object-filter" configuration option. Using a global serial filter will impact performance.
Affected configurations
• apache geode (<= 1.12.5)
• apache geode (>= 1.13.0 <= 1.13.4)
• apache geode 1.14.0
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/qrvhmytsshsk5xcb68pwccw3y6m8o8nr Mailing List, Vendor Advisory
- https://lists.apache.org/thread/qrvhmytsshsk5xcb68pwccw3y6m8o8nr Mailing List, Vendor Advisory