CVEvulnerability
CVE-2022-37022
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-08-31
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
Apache Geode versions up to 1.12.2 and 1.13.2 are vulnerable to a deserialization of untrusted data flaw when using JMX over RMI on Java 11. Any user wishing to protect against deserialization attacks involving JMX or RMI should upgrade to Apache Geode 1.15. Use of 1.15 on Java 11 will automatically protect JMX over RMI against deserialization attacks. This should have no impact on performance since it only affects JMX/RMI which Gfsh uses to communicate with the JMX Manager which is hosted on a Locator.
Affected configurations
• apache geode (<= 1.12.2)
• apache geode (>= 1.13.0 <= 1.13.2)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m Mailing List, Vendor Advisory
- https://lists.apache.org/thread/kr1y4l9752g1ww1shnmh8dbfjq785k4m Mailing List, Vendor Advisory