CVEvulnerability

CVE-2022-37023

6.5 MEDIUM Published 2022-08-31 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-08-31
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-502

Description

Apache Geode versions prior to 1.15.0 are vulnerable to a deserialization of untrusted data flaw when using REST API on Java 8 or Java 11. Any user wishing to protect against deserialization attacks involving REST APIs should upgrade to Apache Geode 1.15 and follow the documentation for details on enabling "validate-serializable-objects=true" and specifying any user classes that may be serialized/deserialized with "serializable-object-filter". Enabling "validate-serializable-objects" may impact performance.

Affected configurations

• apache geode (< 1.15.0)

Related

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References