CVEvulnerability
CVE-2022-37734
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-09-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Description
graphql-java before19.0 is vulnerable to Denial of Service. An attacker can send a malicious GraphQL query that consumes CPU resources. The fixed versions are 19.0 and later, 18.3, and 17.4, and 0.0.0-2022-07-26T05-45-04-226aabd9.
Affected configurations
• graphql-java project graphql-java (< 17.4)
• graphql-java project graphql-java (>= 18.0 < 18.3)
Related
References
- https://github.com/graphql-java/graphql-java/discussions/2958 Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/issues/2888 Issue Tracking, Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/pull/2892 Exploit, Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/releases Release Notes, Third Party Advisory
- https://github.com/graphql-java/graphql-java/discussions/2958 Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/issues/2888 Issue Tracking, Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/pull/2892 Exploit, Patch, Third Party Advisory
- https://github.com/graphql-java/graphql-java/releases Release Notes, Third Party Advisory