CVEvulnerability
CVE-2022-39263
8.1 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-09-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-287
Description
`@next-auth/upstash-redis-adapter` is the Upstash Redis adapter for NextAuth.js, which provides authentication for Next.js. Applications that use `next-auth` Email Provider and `@next-auth/upstash-redis-adapter` before v3.0.2 are affected by this vulnerability. The Upstash Redis adapter implementation did not check for both the identifier (email) and the token, but only checking for the identifier when verifying the token in the email callback flow. An attacker who knows about the victim's email could easily sign in as the victim, given the attacker also knows about the verification token's expired duration. The vulnerability is patched in v3.0.2. A workaround is available. Using Advanced Initialization, developers can check the requests and compare the query's token and identifier before proceeding.
Affected configurations
• nextauth.js next-auth (< 3.0.2)
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9 Patch
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9 Mitigation, Patch, Third Party Advisory
- https://github.com/nextauthjs/next-auth/commit/d16e04848ee703cf797724194d4ad2907fe125a9 Patch
- https://github.com/nextauthjs/next-auth/security/advisories/GHSA-4rxr-27mm-mxq9 Mitigation, Patch, Third Party Advisory