CVEvulnerability

CVE-2022-39284

4.3 MEDIUM Published 2022-10-06 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-10-06
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
2.6 LOW — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N
CVSS 3.1 ([email protected])
4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-665, CWE-732

Description

CodeIgniter is a PHP full-stack web framework. In versions prior to 4.2.7 setting `$secure` or `$httponly` value to `true` in `Config\Cookie` is not reflected in `set_cookie()` or `Response::setCookie()`. As a result cookie values are erroneously exposed to scripts. It should be noted that this vulnerability does not affect session cookies. Users are advised to upgrade to v4.2.7 or later. Users unable to upgrade are advised to manually construct their cookies either by setting the options in code or by constructing Cookie objects. Examples of each workaround are available in the linked GHSA.

Affected configurations

• codeigniter codeigniter (>= 4.0.0 < 4.2.7)

Related

Weakness · CWE (2)

  • CWE-665 Improper Initialization weakness
  • CWE-732 Incorrect Permission Assignment for Critical Resource weakness

References