CVEvulnerability
CVE-2022-39313
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-10-24
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1284
Description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Versions prior to 4.10.17, and prior to 5.2.8 on the 5.x branch, crash when a file download request is received with an invalid byte range, resulting in a Denial of Service. This issue has been patched in versions 4.10.17, and 5.2.8. There are no known workarounds.
Affected configurations
• parseplatform parse-server (< 4.10.17)
• parseplatform parse-server (>= 5.0.0 < 5.2.8)
Related
Weakness · CWE (1)
- CWE-1284 Improper Validation of Specified Quantity in Input weakness