CVEvulnerability

CVE-2022-39315

5.3 MEDIUM Published 2022-10-25 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-10-25
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-204, CWE-209

Description

Kirby is a Content Management System. Prior to versions 3.5.8.2, 3.6.6.2, 3.7.5.1, and 3.8.1, a user enumeration vulnerability affects all Kirby sites with user accounts unless Kirby's API and Panel are disabled in the config. It can only be exploited for targeted attacks because the attack does not scale to brute force. The problem has been patched in Kirby 3.5.8.2, Kirby 3.6.6.2, Kirby 3.7.5.1, and Kirby 3.8.1. In all of the mentioned releases, the maintainers have rewritten the affected code so that the delay is also inserted after the brute force limit is reached.

Affected configurations

• getkirby kirby (< 3.5.8.2) • getkirby kirby (>= 3.6.0 < 3.6.6.2) • getkirby kirby (>= 3.7.0 < 3.7.5.1) • getkirby kirby 3.8.0

Related

Weakness · CWE (2)

  • CWE-204 Observable Response Discrepancy weakness
  • CWE-209 Generation of Error Message Containing Sensitive Information weakness

References