CVEvulnerability
CVE-2022-39327
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2022-10-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78, CWE-94
Description
Azure CLI is the command-line interface for Microsoft Azure. In versions previous to 2.40.0, Azure CLI contains a vulnerability for potential code injection. Critical scenarios are where a hosting machine runs an Azure CLI command where parameter values have been provided by an external source. The vulnerability is only applicable when the Azure CLI command is run on a Windows machine and with any version of PowerShell and when the parameter value contains the `&` or `|` symbols. If any of these prerequisites are not met, this vulnerability is not applicable. Users should upgrade to version 2.40.0 or greater to receive a a mitigation for the vulnerability.
Affected configurations
• microsoft azure command-line interface (< 2.40.0)
Related
References
- https://github.com/Azure/azure-cli/pull/23514 Exploit, Patch, Third Party Advisory
- https://github.com/Azure/azure-cli/pull/24015 Patch, Third Party Advisory
- https://github.com/Azure/azure-cli/security/advisories/GHSA-47xc-9rr2-q7p4 Exploit, Mitigation, Third Party Advisory
- https://github.com/Azure/azure-cli/pull/23514 Exploit, Patch, Third Party Advisory
- https://github.com/Azure/azure-cli/pull/24015 Patch, Third Party Advisory
- https://github.com/Azure/azure-cli/security/advisories/GHSA-47xc-9rr2-q7p4 Exploit, Mitigation, Third Party Advisory