CVEvulnerability
CVE-2022-39386
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-11-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-248
Description
@fastify/websocket provides WebSocket support for Fastify. Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. This has been patched in version 7.1.1 (fastify v4) and version 5.0.1 (fastify v3). There are currently no known workarounds. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions.
Affected configurations
• fastify websocket (>= 6.0.0 < 7.1.1)
• fastify websocket 5.0.0
Related
Weakness · CWE (1)
- CWE-248 Uncaught Exception weakness
References
- https://github.com/fastify/fastify-websocket/security/advisories/GHSA-4pcg-wr6c-h9cq Third Party Advisory
- https://github.com/fastify/fastify-websocket/security/advisories/GHSA-4pcg-wr6c-h9cq Third Party Advisory