CVEvulnerability
CVE-2022-39944
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-10-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-502
Description
In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.
Affected configurations
• apache linkis (<= 1.2.0)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness
References
- https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc Issue Tracking, Third Party Advisory
- https://lists.apache.org/thread/rxytj48q17304snonjtyt5lnlw64gccc Issue Tracking, Third Party Advisory