CVEvulnerability

CVE-2022-39955

9.8 CRITICAL Published 2022-09-20 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-09-20
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
CVSS 3.1 ([email protected])
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-863

Description

The OWASP ModSecurity Core Rule Set (CRS) is affected by a partial rule set bypass by submitting a specially crafted HTTP Content-Type header field that indicates multiple character encoding schemes. A vulnerable back-end can potentially be exploited by declaring multiple Content-Type "charset" names and therefore bypassing the configurable CRS Content-Type header "charset" allow list. An encoded payload can bypass CRS detection this way and may then be decoded by the backend. The legacy CRS versions 3.0.x and 3.1.x are affected, as well as the currently supported versions 3.2.1 and 3.3.2. Integrators and users are advised to upgrade to 3.2.2 and 3.3.3 respectively.

Affected configurations

• owasp owasp modsecurity core rule set (>= 3.0.0 < 3.2.2) • owasp owasp modsecurity core rule set (>= 3.3.0 < 3.3.3) • fedoraproject fedora 35 • fedoraproject fedora 36 • fedoraproject fedora 37 • debian debian linux 10.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References