CVEvulnerability

CVE-2022-40816

6.5 MEDIUM Published 2022-09-27 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-09-27
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-863

Description

Zammad 5.2.1 is vulnerable to Incorrect Access Control. Zammad's asset handling mechanism has logic to ensure that customer users are not able to see personal information of other users. This logic was not effective when used through a web socket connection, so that a logged-in attacker would be able to fetch personal data of other users by querying the Zammad API. This issue is fixed in , 5.2.2.

Affected configurations

• zammad zammad (>= 5.2.0 < 5.2.2)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References