CVEvulnerability

CVE-2022-41318

8.6 HIGH Published 2022-12-25 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-12-25
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N
Weaknesses
CWE-190

Description

A buffer over-read was discovered in libntlmauth in Squid 2.5 through 5.6. Due to incorrect integer-overflow protection, the SSPI and SMB authentication helpers are vulnerable to reading unintended memory locations. In some configurations, cleartext credentials from these locations are sent to a client. This is fixed in 5.7.

Affected configurations

• squid-cache squid (>= 2.5 < 5.7)

Related

Weakness · CWE (1)

  • CWE-190 Integer Overflow or Wraparound weakness

References