CVEvulnerability

CVE-2022-41916

7.5 HIGH Published 2022-11-15 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-11-15
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-193

Description

Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.

Affected configurations

• heimdal project heimdal (< 7.7.1) • debian debian linux 10.0 • debian debian linux 11.0

Related

Weakness · CWE (1)

  • CWE-193 Off-by-one Error weakness

References