CVEvulnerability
CVE-2022-41921
4.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2022-11-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- Weaknesses
- CWE-20, CWE-770
Description
Discourse is an open-source discussion platform. Prior to version 2.9.0.beta13, users can post chat messages of an unlimited length, which can cause a denial of service for other users when posting huge amounts of text. Users should upgrade to version 2.9.0.beta13, where a limit has been introduced. No known workarounds are available.
Affected configurations
• discourse discourse (< 2.9.0)
• discourse discourse 2.9.0
Related
References
- https://github.com/discourse/discourse/commit/3de765c89524a526ce611e11468d758a471a933f Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-mfh7-6cv6-qccc Third Party Advisory
- https://github.com/discourse/discourse/commit/3de765c89524a526ce611e11468d758a471a933f Patch, Third Party Advisory
- https://github.com/discourse/discourse/security/advisories/GHSA-mfh7-6cv6-qccc Third Party Advisory