CVEvulnerability
CVE-2022-41948
7.2 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-12-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:L
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
DHIS 2 is an open source information system for data capture, management, validation, analytics and visualization. Affected versions are subject to a privilege escalation vulnerability. A DHIS2 user with authority to manage users can assign superuser privileges to themself by manually crafting an HTTP PUT request. Only users with the following DHIS2 user role authorities can exploit this vulnerability. Note that in many systems the only users with user admin privileges are also superusers. In these cases, the escalation vulnerability does not exist. The vulnerability is only exploitable by attackers who can authenticate as users with the user admin authority. As this is usually a small and relatively trusted set of users, exploit vectors will often be limited. DHIS2 administrators should upgrade to the following hotfix releases: 2.36.12.1, 2.37.8.1, 2.38.2.1, 2.39.0.1. The only known workaround to this issue is to avoid the assignment of the user management authority to any users until the patch has been applied.
Affected configurations
• dhis2 dhis 2 (>= 2.34.0 < 2.36.12.1)
• dhis2 dhis 2 (>= 2.37.0 < 2.37.8.1)
• dhis2 dhis 2 (>= 2.38.0 < 2.38.2.1)
• dhis2 dhis 2 2.39.0
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://github.com/dhis2/dhis2-core/security/advisories/GHSA-59fm-8432-2426 Third Party Advisory
- https://github.com/dhis2/dhis2-core/security/advisories/GHSA-59fm-8432-2426 Third Party Advisory