CVEvulnerability
CVE-2022-42009
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-07-12
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-917
Description
SpringEL injection in the server agent in Apache Ambari version 2.7.0 to 2.7.6 allows a malicious authenticated user to execute arbitrary code remotely. Users are recommended to upgrade to 2.7.7.
Affected configurations
• apache ambari (>= 2.7.0 < 2.7.7)
Related
Weakness · CWE (1)
- CWE-917 Improper Neutralization of Special Elements used in an Expression Language Statement weakness
References
- https://lists.apache.org/thread/6xf477ttz1oxmg0bx0tpdoz2mlqd7sbc Mailing List, Vendor Advisory
- https://lists.apache.org/thread/6xf477ttz1oxmg0bx0tpdoz2mlqd7sbc Mailing List, Vendor Advisory