CVEvulnerability

CVE-2022-42890

7.5 HIGH Published 2022-10-25 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-10-25
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-918

Description

A vulnerability in Batik of Apache XML Graphics allows an attacker to run Java code from untrusted SVG via JavaScript. This issue affects Apache XML Graphics prior to 1.16. Users are recommended to upgrade to version 1.16.

Affected configurations

• apache batik (>= 1.0 < 1.16) • debian debian linux 10.0 • debian debian linux 11.0

Related

Weakness · CWE (1)

  • CWE-918 Server-Side Request Forgery weakness

References