CVEvulnerability
CVE-2022-43766
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2022-10-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.
Affected configurations
• apache iotdb (>= 0.12.2 <= 0.12.6)
• apache iotdb (>= 0.13.0 <= 0.13.2)
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://lists.apache.org/thread/9pgpb82p5brooy41n8l5q0y9h33db2zn Mailing List, Vendor Advisory
- https://lists.apache.org/thread/9pgpb82p5brooy41n8l5q0y9h33db2zn Mailing List, Vendor Advisory