CVEvulnerability
CVE-2022-45064
9.0 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2023-04-13
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.0 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-79
Description
The SlingRequestDispatcher doesn't correctly implement the RequestDispatcher API resulting in a generic type of include-based cross-site scripting issues on the Apache Sling level. The vulnerability is exploitable by an attacker that is able to include a resource with specific content-type and control the include path (i.e. writing content). The impact of a successful attack is privilege escalation to administrative power.
Please update to Apache Sling Engine >= 2.14.0 and enable the "Check Content-Type overrides" configuration option.
Affected configurations
• apache apache sling engine (< 2.14.0)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- http://www.openwall.com/lists/oss-security/2023/04/18/6 Mailing List
- https://lists.apache.org/thread/hhp611hltby3whk03vx2mv7cmy3vs0ok Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2023/04/18/6 Mailing List
- https://lists.apache.org/thread/hhp611hltby3whk03vx2mv7cmy3vs0ok Mailing List, Vendor Advisory