CVEvulnerability

CVE-2022-46258

6.5 MEDIUM Published 2023-01-09 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-01-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-863

Description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.3.16) • github enterprise server (>= 3.4.0 < 3.4.11) • github enterprise server (>= 3.5.0 < 3.5.8) • github enterprise server (>= 3.6.0 < 3.6.4)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References