CVEvulnerability

CVE-2022-46792

8.8 HIGH Published 2022-12-08 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2022-12-08
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-863

Description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

Affected configurations

• hasura graphql engine (>= 2.10.0 < 2.10.2) • hasura graphql engine (>= 2.11.0 < 2.11.3) • hasura graphql engine (>= 2.13.0 < 2.13.2) • hasura graphql engine (>= 2.15.0 < 2.15.2) • hasura graphql engine 2.12.0 • hasura graphql engine 2.14.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References