CVEvulnerability
CVE-2022-4876
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-01-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.
Affected configurations
• kaltura mwembed (<= 2.95)
• kaltura mwembed 2.96
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b Patch
- https://github.com/kaltura/mwEmbed/pull/4266 Patch
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2 Release Notes
- https://vuldb.com/?ctiid.217427 Permissions Required
- https://vuldb.com/?id.217427 Third Party Advisory
- https://github.com/kaltura/mwEmbed/commit/13b8812ebc8c9fa034eed91ab35ba8423a528c0b Patch
- https://github.com/kaltura/mwEmbed/pull/4266 Patch
- https://github.com/kaltura/mwEmbed/releases/tag/v2.96.rc2 Release Notes
- https://vuldb.com/?ctiid.217427 Permissions Required
- https://vuldb.com/?id.217427 Third Party Advisory