CVEvulnerability
CVE-2022-4877
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-01-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A vulnerability has been found in snoyberg keter up to 1.8.1 and classified as problematic. This vulnerability affects unknown code of the file Keter/Proxy.hs. The manipulation of the argument host leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 1.8.2 is able to address this issue. The name of the patch is d41f3697926b231782a3ad8050f5af1ce5cc40b7. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217444.
Affected configurations
• keter project keter (< 1.8.2)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/snoyberg/keter/commit/d41f3697926b231782a3ad8050f5af1ce5cc40b7 Patch, Third Party Advisory
- https://github.com/snoyberg/keter/pull/246 Patch, Third Party Advisory
- https://github.com/snoyberg/keter/releases/tag/keter%2F1.8.2 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.217444 Third Party Advisory
- https://vuldb.com/?id.217444 Third Party Advisory
- https://github.com/snoyberg/keter/commit/d41f3697926b231782a3ad8050f5af1ce5cc40b7 Patch, Third Party Advisory
- https://github.com/snoyberg/keter/pull/246 Patch, Third Party Advisory
- https://github.com/snoyberg/keter/releases/tag/keter%2F1.8.2 Release Notes, Third Party Advisory
- https://vuldb.com/?ctiid.217444 Third Party Advisory
- https://vuldb.com/?id.217444 Third Party Advisory