CVEvulnerability
CVE-2022-4885
5.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-01-11
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.0 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- CVSS 2.0 ([email protected])
- 5.1 MEDIUM — AV:N/AC:H/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-22
Description
A vulnerability has been found in sviehb jefferson up to 0.3 and classified as critical. This vulnerability affects unknown code of the file src/scripts/jefferson. The manipulation leads to path traversal. The attack can be initiated remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 0.4 is able to address this issue. The name of the patch is 53b3f2fc34af0bb32afbcee29d18213e61471d87. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-218020.
Affected configurations
• jefferson project jefferson (< 0.4)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/sviehb/jefferson/commit/53b3f2fc34af0bb32afbcee29d18213e61471d87 Patch
- https://github.com/sviehb/jefferson/pull/36 Patch
- https://github.com/sviehb/jefferson/releases/tag/v0.4 Release Notes
- https://vuldb.com/?ctiid.218020 Permissions Required
- https://vuldb.com/?id.218020 Permissions Required
- https://github.com/sviehb/jefferson/commit/53b3f2fc34af0bb32afbcee29d18213e61471d87 Patch
- https://github.com/sviehb/jefferson/pull/36 Patch
- https://github.com/sviehb/jefferson/releases/tag/v0.4 Release Notes
- https://vuldb.com/?ctiid.218020 Permissions Required
- https://vuldb.com/?id.218020 Permissions Required