CVEvulnerability
CVE-2022-4929
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-03-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 2.0 ([email protected])
- 4.0 MEDIUM — AV:N/AC:L/Au:S/C:N/I:P/A:N
- Weaknesses
- CWE-79
Description
A vulnerability was found in icplayer up to 0.818. It has been rated as problematic. Affected by this issue is some unknown functionality of the file addons/Commons/src/tts-utils.js. The manipulation leads to cross site scripting. The attack may be launched remotely. Upgrading to version 0.819 is able to address this issue. The patch is identified as fa785969f213c76384f1fe67d47b17d57fcc60c8. It is recommended to upgrade the affected component. VDB-222290 is the identifier assigned to this vulnerability.
Affected configurations
• learnetic icplayer (< 0.819)
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/icplayer/icplayer/commit/fa785969f213c76384f1fe67d47b17d57fcc60c8 Patch
- https://github.com/icplayer/icplayer/pull/885 Patch
- https://github.com/icplayer/icplayer/releases/tag/v0.819 Release Notes
- https://vuldb.com/?ctiid.222290 Permissions Required
- https://vuldb.com/?id.222290 Permissions Required
- https://github.com/icplayer/icplayer/commit/fa785969f213c76384f1fe67d47b17d57fcc60c8 Patch
- https://github.com/icplayer/icplayer/pull/885 Patch
- https://github.com/icplayer/icplayer/releases/tag/v0.819 Release Notes
- https://vuldb.com/?ctiid.222290 Permissions Required
- https://vuldb.com/?id.222290 Permissions Required