CVEvulnerability

CVE-2023-0872

8.0 HIGH Published 2023-08-14 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-08-14
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.2 HIGH — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:L/I:H/A:L
CVSS 3.1 ([email protected])
8.0 HIGH — CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-269

Description

The Horizon REST API includes a users endpoint in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms is vulnerable to elevation of privilege. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Erik Wynter for reporting this issue.

Affected configurations

• opennms horizon (>= 31.0.8 < 32.0.2) • opennms meridian (>= 2020.0.0 <= 2020.1.37) • opennms meridian (>= 2021.0.0 <= 2021.1.29) • opennms meridian (>= 2022.0.0 <= 2022.1.18) • opennms meridian (>= 2023.0.0 <= 2023.1.5)

Related

Weakness · CWE (1)

  • CWE-269 Improper Privilege Management weakness

References