CVEvulnerability
CVE-2023-20873
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-04-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Description
In Spring Boot versions 3.0.0 - 3.0.5, 2.7.0 - 2.7.10, and older unsupported versions, an application that is deployed to Cloud Foundry could be susceptible to a security bypass. Users of affected versions should apply the following mitigation: 3.0.x users should upgrade to 3.0.6+. 2.7.x users should upgrade to 2.7.11+. Users of older, unsupported versions should upgrade to 3.0.6+ or 2.7.11+.
Affected configurations
• vmware spring boot (< 2.5.15)
• vmware spring boot (>= 2.6.0 < 2.6.14)
• vmware spring boot (>= 2.7.0 < 2.7.11)
• vmware spring boot (>= 3.0.0 < 3.0.6)
References
- https://security.netapp.com/advisory/ntap-20230601-0009/ Third Party Advisory
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now spring.io
- https://spring.io/security/cve-2023-20873 Vendor Advisory
- https://security.netapp.com/advisory/ntap-20230601-0009/ Third Party Advisory
- https://spring.io/blog/2023/05/18/spring-boot-2-5-15-and-2-6-15-available-now spring.io
- https://spring.io/security/cve-2023-20873 Vendor Advisory