CVEvulnerability
CVE-2023-22480
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-01-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-285, CWE-863
Description
KubeOperator is an open source Kubernetes distribution focused on helping enterprises plan, deploy and operate production-level K8s clusters. In KubeOperator versions 3.16.3 and below, API interfaces with unauthorized entities and can leak sensitive information. This vulnerability could be used to take over the cluster under certain conditions. This issue has been patched in version 3.16.4.
Affected configurations
• fit2cloud kubeoperator (< 3.16.4)
Related
References
- https://github.com/KubeOperator/KubeOperator/commit/7ef42bf1c16900d13e6376f8be5ecdbfdfb44aaf Patch, Third Party Advisory
- https://github.com/KubeOperator/KubeOperator/releases/tag/v3.16.4 Release Notes, Third Party Advisory
- https://github.com/KubeOperator/KubeOperator/security/advisories/GHSA-jxgp-jgh3-8jc8 Patch, Third Party Advisory
- https://github.com/KubeOperator/KubeOperator/commit/7ef42bf1c16900d13e6376f8be5ecdbfdfb44aaf Patch, Third Party Advisory
- https://github.com/KubeOperator/KubeOperator/releases/tag/v3.16.4 Release Notes, Third Party Advisory
- https://github.com/KubeOperator/KubeOperator/security/advisories/GHSA-jxgp-jgh3-8jc8 Patch, Third Party Advisory