CVEvulnerability
CVE-2023-22731
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-01-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
Shopware is an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment **without the Sandbox extension**, it is possible to refer to PHP functions in twig filters like `map`, `filter`, `sort`. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this vulnerability. This problem has been fixed with 6.4.18.1 with an override of the specified filters until the integration of the Sandbox extension has been finished. Users are advised to upgrade. Users of major versions 6.1, 6.2, and 6.3 may also receive this fix via a plugin.
Affected configurations
• shopware shopware (< 6.4.18.1)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates Patch, Vendor Advisory
- https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1 Patch, Third Party Advisory
- https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w Third Party Advisory
- https://docs.shopware.com/en/shopware-6-en/security-updates/security-update-01-2023?category=security-updates Patch, Vendor Advisory
- https://github.com/shopware/platform/commit/89d1ea154689cb6202e0d3a0ceeae0febb0c09e1 Patch, Third Party Advisory
- https://github.com/shopware/platform/security/advisories/GHSA-93cw-f5jj-x85w Third Party Advisory