CVEvulnerability
CVE-2023-22946
9.9 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-04-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
In Apache Spark versions prior to 3.4.0, applications using spark-submit can specify a 'proxy-user' to run as, limiting privileges. The application can execute code with the privileges of the submitting user, however, by providing malicious configuration-related classes on the classpath. This affects architectures relying on proxy-user, for example those using Apache Livy to manage submitted applications.
Update to Apache Spark 3.4.0 or later, and ensure that
spark.submit.proxyUser.allowCustomClasspathInClusterMode is set to its
default of "false", and is not overridden by submitted applications.
Affected configurations
• apache spark (< 3.4.0)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv Mailing List, Vendor Advisory
- https://lists.apache.org/thread/yllfl25xh5tbotjmg93zrq4bzwhqc0gv Mailing List, Vendor Advisory