CVEvulnerability
CVE-2023-23613
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-01-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.7 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-200
Description
OpenSearch is an open source distributed and RESTful search engine. In affected versions there is an issue in the implementation of field-level security (FLS) and field masking where rules written to explicitly exclude fields are not correctly applied for certain queries that rely on their auto-generated .keyword fields. This issue is only present for authenticated users with read access to the indexes containing the restricted fields. This may expose data which may otherwise not be accessible to the user. OpenSearch 1.0.0-1.3.7 and 2.0.0-2.4.1 are affected. Users are advised to upgrade to OpenSearch 1.3.8 or 2.5.0. Users unable to upgrade may write explicit exclusion rules as a workaround. Policies authored in this way are not subject to this issue.
Affected configurations
• amazon opensearch (>= 1.0.0 < 1.3.8)
• amazon opensearch (>= 2.0.0 < 2.5.0)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0 Third Party Advisory
- https://github.com/opensearch-project/security/security/advisories/GHSA-v3cg-7r9h-r2g6 Third Party Advisory
- https://github.com/opensearch-project/OpenSearch/releases/tag/2.5.0 Third Party Advisory
- https://github.com/opensearch-project/security/security/advisories/GHSA-v3cg-7r9h-r2g6 Third Party Advisory