CVEvulnerability

CVE-2023-23761

5.3 MEDIUM Published 2023-04-07 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2023-04-07
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
7.7 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:N
CVSS 3.1 ([email protected])
5.3 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:N/I:H/A:N
Weaknesses
CWE-287

Description

An improper authentication vulnerability was identified in GitHub Enterprise Server that allowed an unauthorized actor to modify other users' secret gists by authenticating through an SSH certificate authority. To do so, a user had to know the secret gist's URL. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.9 and was fixed in versions 3.4.18, 3.5.15, 3.6.11, 3.7.8, and 3.8.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.4.18) • github enterprise server (>= 3.5.0 < 3.5.15) • github enterprise server (>= 3.6.0 < 3.6.11) • github enterprise server (>= 3.7.0 < 3.7.8) • github enterprise server 3.8.0

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References