CVEvulnerability
CVE-2023-24809
5.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2023-02-17
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 5.5 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-120
Description
NetHack is a single player dungeon exploration game. Starting with version 3.6.2 and prior to version 3.6.7, illegal input to the "C" (call) command can cause a buffer overflow and crash the NetHack process. This vulnerability may be a security issue for systems that have NetHack installed suid/sgid and for shared systems. For all systems, it may result in a process crash. This issue is resolved in NetHack 3.6.7. There are no known workarounds.
Affected configurations
• nethack nethack (>= 3.6.2 < 3.6.7)
Related
Weakness · CWE (1)
- CWE-120 Buffer Copy without Checking Size of Input weakness
References
- https://github.com/NetHack/NetHack/security/advisories/GHSA-2cqv-5w4v-mgch Vendor Advisory
- https://nethack.org/security/CVE-2023-24809.html Vendor Advisory
- https://github.com/NetHack/NetHack/security/advisories/GHSA-2cqv-5w4v-mgch Vendor Advisory
- https://nethack.org/security/CVE-2023-24809.html Vendor Advisory