CVEvulnerability
CVE-2023-25157
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-02-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. GeoServer includes support for the OGC Filter expression language and the OGC Common Query Language (CQL) as part of the Web Feature Service (WFS) and Web Map Service (WMS) protocols. CQL is also supported through the Web Coverage Service (WCS) protocol for ImageMosaic coverages. Users are advised to upgrade to either version 2.21.4, or version 2.22.2 to resolve this issue. Users unable to upgrade should disable the PostGIS Datastore *encode functions* setting to mitigate ``strEndsWith``, ``strStartsWith`` and ``PropertyIsLike `` misuse and enable the PostGIS DataStore *preparedStatements* setting to mitigate the ``FeatureId`` misuse.
Affected configurations
• osgeo geoserver (< 2.18.7)
• osgeo geoserver (>= 2.19.0 < 2.19.7)
• osgeo geoserver (>= 2.20.0 < 2.20.7)
• osgeo geoserver (>= 2.21.0 < 2.21.4)
• osgeo geoserver (>= 2.22.0 < 2.22.2)
Related
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness
References
- https://github.com/geoserver/geoserver/commit/145a8af798590288d270b240235e89c8f0b62e1d Patch
- https://github.com/geoserver/geoserver/security/advisories/GHSA-7g5f-wrx8-5ccf Vendor Advisory
- https://github.com/geoserver/geoserver/commit/145a8af798590288d270b240235e89c8f0b62e1d Patch
- https://github.com/geoserver/geoserver/security/advisories/GHSA-7g5f-wrx8-5ccf Vendor Advisory