CVEvulnerability
CVE-2023-25567
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-02-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-125
Description
GSS-NTLMSSP, a mechglue plugin for the GSSAPI library that implements NTLM authentication, has an out-of-bounds read when decoding target information prior to version 1.2.0. The length of the `av_pair` is not checked properly for two of the elements which can trigger an out-of-bound read. The out-of-bounds read can be triggered via the main `gss_accept_sec_context` entry point and could cause a denial-of-service if the memory is unmapped. The issue is fixed in version 1.2.0.
Affected configurations
• gss-ntlmssp project gss-ntlmssp (< 1.2.0)
Related
Weakness · CWE (1)
- CWE-125 Out-of-bounds Read weakness
References
- https://github.com/gssapi/gss-ntlmssp/commit/025fbb756d44ffee8f847db4222ed6aa4bd1fbe4 Patch, Third Party Advisory
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0 Third Party Advisory
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-24pf-6prf-24ch Third Party Advisory
- https://github.com/gssapi/gss-ntlmssp/commit/025fbb756d44ffee8f847db4222ed6aa4bd1fbe4 Patch, Third Party Advisory
- https://github.com/gssapi/gss-ntlmssp/releases/tag/v1.2.0 Third Party Advisory
- https://github.com/gssapi/gss-ntlmssp/security/advisories/GHSA-24pf-6prf-24ch Third Party Advisory