CVEvulnerability
CVE-2023-25805
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-02-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-77
Description
versionn, software for changing version information across multiple files, has a command injection vulnerability in all versions prior to version 1.1.0. This issue is patched in version 1.1.0.
Affected configurations
• versionn project versionn (< 1.1.0)
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d Patch
- https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm Third Party Advisory
- https://github.com/commenthol/versionn/commit/2ca128823efe962b37f2698f0eb530c2b124842d Patch
- https://github.com/commenthol/versionn/security/advisories/GHSA-fj78-2vc5-f6cm Third Party Advisory