CVEvulnerability

CVE-2023-25957

7.5 HIGH Published 2023-03-14 Modified 2026-10-23 Official page ↗
Status
Modified
Published
2023-03-14
Last modified
2026-10-23
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1 ([email protected])
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-287, CWE-303

Description

A vulnerability has been identified in Mendix SAML (Mendix 7 compatible) (All versions >= V1.16.4 < V1.17.3), Mendix SAML (Mendix 8 compatible) (All versions >= V2.2.0 < V2.3.0), Mendix SAML (Mendix 9 latest compatible, New Track) (All versions >= V3.1.9 < V3.3.1), Mendix SAML (Mendix 9 latest compatible, Upgrade Track) (All versions >= V3.1.8 < V3.3.0), Mendix SAML (Mendix 9.6 compatible, New Track) (All versions >= V3.1.9 < V3.2.7), Mendix SAML (Mendix 9.6 compatible, Upgrade Track) (All versions >= V3.1.8 < V3.2.6). The affected versions of the module insufficiently verify the SAML assertions. This could allow unauthenticated remote attackers to bypass authentication and get access to the application. For compatibility reasons, fix versions still contain this issue, but only when the recommended, default configuration option `'Use Encryption'` is disabled.

Affected configurations

• mendix saml (>= 1.16.4 < 1.17.2) • mendix saml (>= 2.2.0 < 2.2.3) • mendix saml (>= 3.1.9 < 3.2.5)

Related

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-303 Incorrect Implementation of Authentication Algorithm weakness

References