CVEvulnerability
CVE-2023-26482
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.0 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-78
Description
Nextcloud server is an open source home cloud implementation. In affected versions a missing scope validation allowed users to create workflows which are designed to be only available for administrators. Some workflows are designed to be RCE by invoking defined scripts, in order to generate PDFs, invoking webhooks or running scripts on the server. Due to this combination depending on the available apps the issue can result in a RCE at the end. It is recommended that the Nextcloud Server is upgraded to 24.0.10 or 25.0.4. Users unable to upgrade should disable app `workflow_scripts` and `workflow_pdf_converter` as a mitigation.
Affected configurations
• nextcloud nextcloud server (>= 18.0.0 < 20.0.14.12)
• nextcloud nextcloud server (>= 21.0.0 < 21.0.9.10)
• nextcloud nextcloud server (>= 22.0.0 < 22.2.10.10)
• nextcloud nextcloud server (>= 23.0.0 < 23.0.12.5)
• nextcloud nextcloud server (>= 24.0.0 < 24.0.10)
• nextcloud nextcloud server (>= 25.0.0 < 25.0.4)
Related
Weakness · CWE (1)
- CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj Vendor Advisory
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60 Patch
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-h3c9-cmh8-7qpj Vendor Advisory
- https://github.com/nextcloud/server/commit/5a06b50b10cc9278bbe68bbf897a0c4aeb0c4e60 Patch