CVEvulnerability
CVE-2023-27491
9.1 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-04-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-20, CWE-444
Description
Envoy is an open source edge and service proxy designed for cloud-native applications. Compliant HTTP/1 service should reject malformed request lines. Prior to versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9, There is a possibility that non compliant HTTP/1 service may allow malformed requests, potentially leading to a bypass of security policies. This issue is fixed in versions 1.26.0, 1.25.3, 1.24.4, 1.23.6, and 1.22.9.
Affected configurations
• envoyproxy envoy (< 1.22.9)
• envoyproxy envoy (>= 1.23.0 < 1.23.6)
• envoyproxy envoy (>= 1.24.0 < 1.24.4)
• envoyproxy envoy (>= 1.25.0 < 1.25.3)
Related
References
- https://datatracker.ietf.org/doc/html/rfc9113#section-8.3 Not Applicable
- https://datatracker.ietf.org/doc/html/rfc9114#section-4.3.1 Not Applicable
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp Exploit, Vendor Advisory
- https://www.rfc-editor.org/rfc/rfc9110#section-5.6.2 Not Applicable
- https://datatracker.ietf.org/doc/html/rfc9113#section-8.3 Not Applicable
- https://datatracker.ietf.org/doc/html/rfc9114#section-4.3.1 Not Applicable
- https://github.com/envoyproxy/envoy/security/advisories/GHSA-5jmv-cw9p-f9rp Exploit, Vendor Advisory
- https://www.rfc-editor.org/rfc/rfc9110#section-5.6.2 Not Applicable