CVEvulnerability
CVE-2023-27597
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.8 and 3.2.5, when a specially crafted SIP message is processed by the function `rewrite_ruri`, a crash occurs due to a segmentation fault. This issue causes the server to crash. It affects configurations containing functions that make use of the affected code, such as the function `setport`. This issue has been fixed in version 3.1.8 and 3.2.5.
Affected configurations
• opensips opensips (< 3.1.8)
• opensips opensips (>= 3.2.0 < 3.2.5)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/OpenSIPS/opensips/commit/b2dffe4b5cd81182c9c8eabb6c96aac96c7acfe3 Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-358f-935m-7p9c Third Party Advisory
- https://github.com/OpenSIPS/opensips/commit/b2dffe4b5cd81182c9c8eabb6c96aac96c7acfe3 Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-358f-935m-7p9c Third Party Advisory