CVEvulnerability
CVE-2023-27599
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, when the function `append_hf` handles a SIP message with a malformed To header, a call to the function `abort()` is performed, resulting in a crash. This is due to the following check in `data_lump.c:399` in the function `anchor_lump`. An attacker abusing this vulnerability will crash OpenSIPS leading to Denial of Service. It affects configurations containing functions that make use of the affected code, such as the function `append_hf`. This issue has been fixed in versions 3.1.7 and 3.2.4.
Affected configurations
• opensips opensips (< 3.1.7)
• opensips opensips (>= 3.2.0 < 3.2.4)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/OpenSIPS/opensips/commit/cb56694d290530ac308f44b453c18120b1c1109d Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qvj2-vqrg-f5jx Third Party Advisory
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf Third Party Advisory
- https://github.com/OpenSIPS/opensips/commit/cb56694d290530ac308f44b453c18120b1c1109d Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-qvj2-vqrg-f5jx Third Party Advisory
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf Third Party Advisory