CVEvulnerability
CVE-2023-28095
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2023-03-15
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Versions prior to 3.1.7 and 3.2.4 have a potential issue in `msg_translator.c:2628` which might lead to a server crash. This issue was found while fuzzing the function `build_res_buf_from_sip_req` but could not be reproduced against a running instance of OpenSIPS. This issue could not be exploited against a running instance of OpenSIPS since no public function was found to make use of this vulnerable code. Even in the case of exploitation through unknown vectors, it is highly unlikely that this issue would lead to anything other than Denial of Service. This issue has been fixed in versions 3.1.7 and 3.2.4.
Affected configurations
• opensips opensips (< 3.1.7)
• opensips opensips (>= 3.2.0 < 3.2.4)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/OpenSIPS/opensips/commit/9cf3dd3398719dd91207495f76d7726701c5145c Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-7pf3-24qg-8v9h Third Party Advisory
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf Vendor Advisory
- https://github.com/OpenSIPS/opensips/commit/9cf3dd3398719dd91207495f76d7726701c5145c Patch, Third Party Advisory
- https://github.com/OpenSIPS/opensips/security/advisories/GHSA-7pf3-24qg-8v9h Third Party Advisory
- https://opensips.org/pub/audit-2022/opensips-audit-technical-report-full.pdf Vendor Advisory